Supported Software

It is important that, whenever possible, you use supported versions of software on your computers, tablets, smartphones, and other internet-capable devices. If you use software for which a vendor does not provide security updates, you could endanger information stored on your computer or device and your computer or network accounts. The best way you can protect your computer is through enabling automatic software updates, and allowing them to run as frequently as possible.

This list of versions of major software packages supported by the vendors and by the University was last updated in July 2018.

For information about software not listed on this page, consult the vendor's website, contact your department or college's IT professionals or contact the IT Support Center.

Operating systems

  • Android—Visit the Android Support Library for information on the latest supported versions.
  • iOS—Version 9 x or later, visit the iOS Support Matrix for information on the latest supported versions.
  • macOS—Version 10.11 (El Capitan) or later, visit Apple Support for information on the latest supported versions.
  • Windows—Windows 10 or later (mainstream support for Windows 7 and 8.1 has ended), visit Microsoft Windows Support for information on the latest supported versions.
  • Linux Distributions—Visit the Distrowatch website for information on the latest supported versions.

Web browsers

Security-related software

  • Any Connect VPN client software—Version 4 or later, visit UDeploy to download the latest version.
  • PuTTY—Version 0.70 or later, visit UDeploy to download the latest version.
  • WinSCP—Version 5.13 or later, visit UDeploy to download the latest version.

Other software

  • Adobe—Visit the Adobe Supported Product Versions for information on the latest supported versions of various Adobe products including Adobe Acrobat and Adobe Flash Player.
  • Apache—Version 2.4 x or later, visit the Apache website for information on the latest supported versions.
  • Java—Version 11 or later, visit Oracle Java SE Support for information on the latest supported versions.
  • Microsoft Office—Visit Microsoft's lifecycle Web page for supported versions of various Microsoft products. Support for all components of Microsoft Office 2007 ended on October 10, 2017.
  • OpenSSH—Version 7.7 or later, visit OpenSSH Release Notes for information on the latest supported versions.
  • OpenSSL—Series 1.1.0 or later, visit the OpenSSL website for information on the latest supported versions.
  • PHP—Version 7.x is the latest stable version. All support for PHP 5.x will end on December 31, 2018. Visit PHP's website for more information.

Search IT Help

My UD Search for forms & applications.