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Creating Charts,
Graphs, Tables,
and Equations

After completing this chapter, you will be able to:

� Use a datasheet to create a chart or graph some data you want to display on-screen

� Choose the proper type of chart for the kind of data you are presenting

� Use tables to display data neatly in columns and rows on the screen

� Display equations via the equation editor

� Understand the difference between object linking and embedding

� Link or embed objects created with other programs

� Animate charts, graphs, tables, and formulas

� The ancient Greek mathematician Pythagoras claimed that all things are known by number. Sooner or later, in the

midst of all your multimedia sound and graphics, you will inevitably encounter the need to display

numerical data on the screen. You may want to display a graph showing how much something has

grown during the past decade, for example, or you may need to forecast a future trend that

requires you to graph numerical or financial projections. Happily, PowerPoint has a datasheet that

makes it easy to create charts and graphs.

There will also be times when you need to display numerical or textual information in rows and

columns on the screen. You may need to compare the features of two competing products, for

example, or explain the relative advantages and disadvantages of different ways to solve a

problem. PowerPoint’s table feature can help you organize the screen into rows and columns that

make side-by-side comparisons easy to present.

If the data you are presenting follows a numerical formula, you can use the Equation Editor to

display the formula’s equation on-screen. This chapter not only enables you to do all these things,

but it also shows you how to use animation techniques to move the data on and off the screen in

an engaging manner through multimedia sound and graphics.
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Creating Charts and Graphs
To create a chart or graph some data, type or paste your numerical data into a special
table called a datasheet. When the chart appears on-screen, you can alter its display
settings to present your data in the most effective manner. Follow these steps:

� Go to the slide on which you want to create a chart or graph. In this example, open
your Practice application, go to the last slide, and click the New Slide icon to create a
new slide.

� Pull down the Insert menu and choose Chart; if the Chart option is not visible, click the
down-arrow to reveal the rest of the menu.

� The chart appears on-screen with a sample set of data displayed in it, as illustrated in
Figure 38-1. Beneath the chart is the datasheet, as illustrated in Figure 38-2. Compare
these two figures, and notice how the chart graphs the numbers in the datasheet.

� The first row of the datasheet contains the data labels. Click each label and type the
label for the corresponding column in your data. To delete a label, click it to select it,
then press d. To delete an entire column, right-click the label, and when the menu
pops up, choose Delete, then choose Entire Column.

� The first column of the datasheet contains the series labels. Click each label and type
the label for the corresponding row in your data. To delete a label, click it to select it,
then press d. To delete an entire row, right-click the label, and when the menu pops
up, choose Delete, then choose Entire Row.

� The rest of the datasheet contains the data displayed in the chart. Click each cell and
type the data you want displayed. To delete a cell, click it to select it, then press d.
To delete an entire row or column of data, right-click a cell, and when the menu pops
out, choose Delete, then select Entire Column or Entire Row.

Show-Me Movie:
“Creating a Chart”

Figure 38-1 This chart appears when you pull down the Insert
menu and choose Chart.

Figure 38-2 The datasheet table; this is the data that is
displayed in Figure 38-1.
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Choosing a Type of Chart Appropriate to Your Data
There are dozens of types of charts in which you can display your data. To change the
chart style, right-click the white space between the chart and its placeholder; when the
menu pops up, choose Chart Type. Figure 38-3 shows how the Chart Type dialog will
appear. It lets you choose among the styles of charts listed in Table 38-1. Following the
advice in Table 38-1, choose the charting style appropriate to your data.

Figure 38-3 The Chart Type dialog.

Table 38-1 Chart Styles and When to Use Them

Type of ChartType of ChartType of ChartType of ChartType of Chart When to Use This TypeWhen to Use This TypeWhen to Use This TypeWhen to Use This TypeWhen to Use This Type

Column Compares values across categories vertically

Bar Compares values across categories horizontally

Line Draws lines with markers displayed at each data point

Pie Displays the contribution of each value to a total

X,Y (Scatter) Compares pairs of values

Area Displays the trend of values over time or categories

Doughnut Functions like a pie chart, but can contain multiple series

Radar Displays changes in values relative to a center point

Surface Shows trends in values across two dimensions in a continuous curve

Bubble Compares sets of three values; a scatter plot in which the size of the bubble represents the third value

Stock Displays from three to five values of each label

Cylinder Compares values across categories with cylindrical columns or bars

Cone Compares values across categories with conical columns or bars

Pyramid Compares values across categories with pyramidal columns or bars
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Importing a File to Create a Chart
If your chart has a lot of data in it, you can save time by importing the data from a file
instead of typing it by hand. You can import data from a Lotus 1-2-3 file, a Microsoft
Excel file, or a plain text file in which the data elements are defined by character position
or are delimited by commas, spaces, or tab characters. To import data from a file, follow
these steps:

� If you do not already have a chart on-screen, pull down the Insert menu and
choose Chart.

� If the datasheet is not visible, right-click the white space just inside the chart’s
placeholder and when the menu pops up, choose Datasheet.

� Click the cell in which you want the imported data to begin; normally, you click the
upper left cell on the datasheet.

� Pull down the Edit menu and click Import File. When the Import File dialog appears,
use the Look In menu to switch to the folder containing the file you want to import.

� Use the Files of Type menu to look for the kind of file you are importing, as illustrated
in Figure 38-4. After you have located the file, click the Open button, and follow the
on-screen instructions to import the data. If you are importing a text file, for example,
the Text Import Wizard appears. Answer the questions the Wizard asks, then click the
Finish button to import the data into the datasheet.

Figure 38-4 The Import File dialog lets you import data from a Lotus 1-2-3 file, a Microsoft Excel
file, or a plain text file.
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Inserting a Table
Whenever you want the user to make side-by-side comparisons of numerical or textual
information, the best way to present the data is to create a table. A table consists of rows
and columns that make side-by-side comparisons easy to present. To create a table,
follow these steps:

� Go to the slide on which you want to create a table. In this example, open your Practice
application, go to the last slide, and click the New Slide icon to create a new slide.

� Pull down the Insert menu and choose Table; if the Table option is not visible, click the
down-arrow to reveal the rest of the menu.

� The Insert Table dialog appears as illustrated in Figure 38-5. Use this dialog to set the
number of rows and columns your table will contain initially. In this example,
designate two columns and seven rows. Click OK, and the table appears on-screen.

Show-Me Movie:
“Inserting a Table”

Figure 38-5 The Insert Table dialog sets the initial
size of the table.

� To enter data into the table, click a cell to select it, then type the data. In this example,
type the following data, which is the elevation of the world’s highest mountains:

Mountain Height
Everest 29,028
K2 28,250
Makalu 27,789
Dhaulagiri 26,810
Nanga Parbat 26,660
Annapurna 26,504

Drawing a Table
PowerPoint has a powerful table drawing capability. To unleash it, pull down the View
menu, choose Toolbars, and select Tables and Borders. The Tables and Borders toolbar
appears as follows:

• Draw Table

• Eraser

• Border Style

• Border Width

• Border Color

Outside Borders • • Fill Color

Table Menu •

Merge Cells  •

Split Cell •

Align Top •

Center Vertically •

Align Bottom •
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To create a table via the Tables and Borders toolbar, follow these steps:

� Go to the slide on which you want to create a table. In this example, open your Practice
application, go to the last slide, and click the New Slide icon to create a new slide.

� If the Tables and Borders toolbar is not visible, pull down the View menu, choose
Toolbars, and select the Tables and Borders toolbar.

� Click the Draw Table tool, which has the shape of a pencil.

� To create the table, click and drag from the spot where you want the table to begin to
the place where you want it to end. Do not worry about being precise, because you
can easily adjust the boundaries of the table later.

� Inside the table you drew in the previous step, click and drag to create the table cells.

� To erase a line in the table, click the Eraser tool, then drag over the line you want
to erase.

� When you finish drawing the table, click a cell and begin typing to enter information
into it.

� Use the Border Style, Border Width, and Border Color tools to change the default line
drawing parameters.

� To change the outside border style, drag to select the cell(s) you want to modify, then
pull down the Outside Borders menu and choose the border style you want.

� To change the fill color of any cell or cells, drag to select the cell(s), then pull down the
Fill Color menu and choose the color or fill style you want.

� By default, the text you type will align to the top of the cell. To change that, click one
of the align tools at the right end of the Tables and Borders toolbar.

� To insert or delete columns or rows above or below the current cell, pull down the
Table menu and choose one of the options illustrated in Figure 38-6.

Figure 38-6 Pulling down the Table menu reveals
tools that let you insert and delete rows and columns.
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Inserting Equations
If you are involved in math, science, or statistics, there may come a time when you need
to display a formula or an equation that you cannot create with PowerPoint’s drawing
tools. Happily, PowerPoint works in conjunction with a more powerful tool called the
Microsoft Equation Editor, which lets you draw any conceivable type of mathematical
equation or formula. To insert an equation onto a PowerPoint slide, follow these steps:

� Go to the slide on which you want to display an equation. In this example, open
your Practice application, go to the last slide, and click the New Slide icon to create
a new slide.

� Pull down the Insert menu and click Object; the Insert Object dialog appears.

� In the Object Type list, click Microsoft Equation 3.0 (or later) and click OK. If Microsoft
Equation is not available in the Object Type list, follow these steps to get it there:

� Pull down the View menu, select Toolbars, then click Customize; the Customize
dialog appears.

� Click the Commands tab, then select Insert in the Categories list.

� In the Commands box, click Equation Editor, then drag it from the Commands
box and put it onto a gray area on the toolbar of your choice.

� Close the dialog box, then click the Equation Editor icon you put on the toolbar.

� Use the Equation Editor to create the equation. The Equation Editor is pretty intuitive,
but if you need help, pull down the Equation Editor’s Help menu and choose Equation
Editor Help Topics.

� To return to PowerPoint, pull down the Equation Editor’s File menu and choose Exit
and Return to Presentation.

� The equation you drew with the Equation Editor now is an object on your
PowerPoint slide.

Editing an Equation
To edit an equation that appears on a PowerPoint slide, follow these steps:

� Double-click the equation; the Equation Editor launches and displays your equation.

� Use the Equation Editor tools and menus to update your equation.

� To return to PowerPoint, pull down the Equation Editor’s File menu and choose Exit
and Return to Presentation.

Object Linking and Embedding
PowerPoint supports object linking and embedding (OLE), which is a process that lets
you insert onto a PowerPoint slide an object that you created with another application
that also supports OLE. All of the applications in the Microsoft Office suite support
OLE, as do a lot of other programs. To insert an object onto a PowerPoint slide, follow
these steps:

� Go to the slide on which you want to insert an object. In this example, open your
Practice application, go to the last slide, and click the New Slide icon to create a
new slide.

� Pull down the Insert menu and click Object; the Insert Object dialog appears.

Show-Me Movie:
“Inserting Equations”
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� Click the option to Insert from file. A browse button appears. Use the browse button to
locate the file that contains the object you want to insert. In this example, browse to
the Midi folder on the Multilit CD, and choose one of the Midi songs you will find there.

� Now you decide whether to check the Link box on the Insert Object dialog. Figure 38-7
shows the location of this important setting. If you do not check the Link box, a copy
of the object will be embedded in your presentation. If you check the Link box,
PowerPoint will use the file you selected, from its current location, instead of copying
it into the presentation.

� Click OK to close the dialog; the link appears on-screen.

� Click the Slide Show button to run your show, and when the link appears, click it and
observe what happens.

Figure 38-7 The Link box on the Insert Object dialog determines whether the object will be
linked or embedded.

You might wonder how to decide whether to link or embed objects created with other
applications. The answer depends on how disciplined you are in file management.
Because when you publish an application, embedded files will get published as part of
your PowerPoint show. Linked files must be published into folders that have the same
relative positioning on the published medium as they did on your development machine.

The advantage of linking is that you conserve file space because there is only one copy of
the file. This also makes applications easier to update. Since there is just one copy of the
linked object, any change you make to it automatically takes place in the applications to
which it is linked. The advantage of embedding an object is that you probably increase
your chances of being able to publish your application reliably. You can also make
changes to the embedded document apart from the original copy.

Animating Charts, Tables, Graphs, and OLE Objects
All of the items you have learned to create in this chapter—charts, tables, graphs, and
equations—are all objects. As objects, they have action settings and can be animated,
just like any other object in a PowerPoint application. Something special happens when
you try to animate a chart, however, because charts have special animation capabilities
in PowerPoint. Follow these steps:

Show-Me Movie:
“Animating Charts”
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� Go to the slide that contains the chart you want to animate. In this example, open your
Practice application, use the Slide Sorter to find the slide on which you created a chart
earlier in this chapter, and double-click the slide to edit it.

� Right-click the chart, and when the menu pops out, choose Custom Animation.

� When the Custom Animation dialog appears, notice how the Chart Effects tab is active.

� In the Check to Animate Slide Objects list, check the box next to your chart. Even more
of the options on the Chart Effects tab activate.

� Pull down the Introduce Chart Elements menu and have a look at your options for
displaying the chart. As illustrated in Figure 38-8, you can introduce your data all at
once, by series, by category, by element in series, and by element in category. For now,
choose by Series.

� Use the Animation and Sound menus to set special effects according to your taste.

� Click the Preview button to preview the effect.

� Click the Order and Timing tab. If you want the data in the slide to appear in sequence
automatically, set the start animation option to Automatically; otherwise, you click
your mouse to sequence through the data.

� Click OK to close the Custom Animation dialog, then click the Slide Show button to
rehearse the animation.

� To make changes in the animation, simply repeat these steps.

Figure 38-8 Pulling down the Introduce Chart Elements menu on the Chart Effects tab of
the Custom Animation dialog.
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e x e r c i s e s
1. Go to the slide in your Practice application that contains the chart you created in this chapter. Play with the

animation effects. What is the most effective way, in your opinion, to present this data? How did you set the
chart’s animation settings? Did you decide to blast the chart onto the screen all at once, or did you choose to
display the data in a sequence? If sequential, did you set the option to display the data automatically, or upon
mouse clicks? Why?

2. Using the Windows Explorer, note the size in bytes of your Practice application. Then go to the last screen of your
Practice application, use the Insert—Object dialog to link (with the link box checked) the greeting.wav file from the
Audio folder of the Multilit CD, and save the Practice application. Using the Windows Explorer, note the revised file
size of the Practice application. How much bigger did it get? Once again, go to the last screen of your Practice
application. This time, use the Insert—Object dialog to embed the greeting.wav file. (Note: To embed the greeting,
make sure the link box is unchecked.) Use the Windows Explorer to note the revised file size of the Practice
application. How does the size compare? How much more did the file size increase when you embedded the
greeting.wav file as compared to when you just linked it?

3. Use the Insert Object menu to create the following equation. Either put it on the last screen of your Practice
application, or create a new screen for it.

x =
2a

–b ± b2 – 4ac




