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Image Capture
and Manipulation

After completing this chapter, you will be able to:

� Install the shareware version of Paint Shop Pro for Windows or Graphic Converter

for the Macintosh

� Capture screens and import images from any software application

� Convert images from one file format into another, such as from BMP into GIF

� Resize images and make color adjustments

� Create special effects with image filters

� Graphics come in a lot of different shapes, sizes, and formats. Developers such as you sometimes need to be able to

manipulate an image to make it suitable for use in a multimedia application. An image might be

too large or too small, for example, or you might want to grab part of an image instead of the

whole picture. You may need to reduce the number of colors to save disk space or to make an

image load more quickly over the Internet. You might want to apply some special effect to the

image, such as emboss, chisel, bevel, weave, sharpen, or soften it.

This chapter teaches you how to do these things with two of the most popular graphics packages

in the world: Paint Shop Pro for Windows and Graphic Converter for the Macintosh. Both are

excellent, all-purpose image-editing programs that can import a picture in dozens of different

image file formats, provide you with powerful tools for editing the image, and export it in any one

of dozens of available image file formats. If you have lots of images to convert, there are batch-

conversion capabilities that can convert multiple images automatically.

Installing the Imaging Software
Paint Shop Pro and Graphic Converter are shareware, which is software that you can try
out before you buy it. If you continue using the programs for more than the free trial
period, you must pay the license fee. Please respect the shareware license by paying the
license fee if you continue using the programs beyond the free trial period.
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Show-Me Movie:
“Creating a Blank Presentation”
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Paint Shop Pro (Windows)
The shareware version of Paint Shop Pro is on the Multilit CD in the psp directory. By
the time you read this, a more advanced version of Paint Shop Pro will probably be
available. Follow the Multilit Web site links to Paint Shop Pro to find out. For the
tutorial printed here, however, you should use the version on the Multilit CD so the
software matches the instructions in the tutorial. Once you master the basics, you can
proceed to more sophisticated versions of Paint Shop Pro. To install Paint Shop Pro
from the Multilit CD, follow these steps:

� Click the Start button and choose Run; the Run dialog appears.

� In the Run dialog, assuming your CD-ROM drive is D, type the following (if your
CD-ROM drive is not D, use the letter of your CD-ROM): d:\psp\setup.exe

� Press œ, and the Paint Shop Pro setup program will begin.

� Follow the on-screen instructions to install Paint Shop Pro.

The first time you run Paint Shop Pro, you must set up the hot key that you will use to
capture graphics. Follow these steps:

� Double-click the Paint Shop Pro icon to run Paint Shop Pro.

� Pull down the Capture menu and choose Setup.

� Figure 34-1 shows how the Capture Setup dialog appears.

� Notice how the Capture group lets you set up to capture an area, the full screen, the
client area of the current window, the entire current window, or an object. Set it to
capture an area.

Figure 34-1 The Paint Shop Pro Capture Setup dialog.

Show-Me Movie:
“Installing Paint Shop Pro”
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� In the Activate Capture group, click the option to activate via Hot Key, and set the hot
key to something you never use in any other application; the author recommends you
set the hot key to ß-_, which is the hot key this tutorial will use.

� Click OK to close the dialog.

Graphic Converter (Macintosh)
Graphic Converter is a shareware program that you download from the Internet and
then install onto your computer. If you have a Macintosh, follow these steps:

� Follow the Multilit Web site link to Graphic Converter.

� Click the Download option.

� Download the version appropriate for your computer (probably the U.S. version, which
is in English).

� The download manager will transfer the program to your computer.

� When the download is finished, there will be a Graphic Converter icon on your
desktop. Double-click the Graphic Converter icon. Stuffit Expander will expand the
downloaded file and put a second Graphic Converter icon on your desktop. Note: If
your computer tells you that it does not have Stuffit Expander, follow the Multilit Web
site link to Stuffit Expander and download it. Then double-click the Graphic Converter
icon to expand the downloaded file.

� Double-click the second Graphic Converter icon to install the software. When the
Install dialog appears, set it to install the software to Macintosh HD, then click the
Install button.

� To put a Graphic Converter launch icon on your desktop that will make it quick and
easy to start Graphic Converter, double-click the Macintosh HD icon, and when the
Macintosh HD contents appears, double-click Graphic Converter to open the Graphic
Converter folder. Control-click the Graphic Converter launch icon and choose the
option to Make Alias, then drag the alias to your desktop.

� To save disk space, at your option, you may drag the first two Graphic Converter
icons into your trash can. Control-click the trash can and choose Empty Trash to free
the disk space.

� Anytime you want to start Graphic Converter, double-click its alias on your desktop.

Capturing Images
A basic skill important to all multimedia developers is the ability to capture an image, or
part of an image, and get it into the window of Paint Shop Pro (Windows) or Graphic
Converter (Macintosh). Follow the steps in Table 34-1.

Show-Me Movie:
“Installing Graphic Converter”

Show-Me Movie:
“Capturing Images”
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Table 34-1 Capturing Images

WindowsWindowsWindowsWindowsWindows MacintoshMacintoshMacintoshMacintoshMacintosh

� Run the program from which you want to capture a graphic. For
example, suppose you want to capture one of the figures on the title
screen of the NECC keynote presentation. Use the Windows Explorer
to look in the Necc folder on the Multilit CD, and double-click the
NECCKeynote to get it running.

� Get Paint Shop Pro running, if it is not running already.

� Hold down a, and keep pressing u until Paint Shop Pro
appears. a-u is a special Windows key for switching among
programs running simultaneously on your computer.

� Pull down Paint Shop Pro’s Capture menu and select Start;
immediately, Paint Shop Pro will disappear.

� If the image you want to capture is not visible on your screen, hold
down a, and keep pressing u until the screen you want to
capture appears.

� Press the capture hot key (ß-_); the cursor turns into a
crosshair.

� Click and drag to select the area of the screen you want to capture,
then release the mouse button.

� The captured image will now appear in the Paint Shop Pro window.
To save the image, pull down the File menu and choose Save As.

� In the Save as Type box, select the image format in which you want to
save the image.

� In the File Name field, type the name you want the image to have.
You do not need to type a filename extension, because Paint Shop Pro
will supply one automatically, based on the file type you set in the
List Files of Type box.

� Click the Save button to save the file, then pull down the File menu
and choose Exit to leave Paint Shop Pro.

Note: To capture the full screen or the contents of a window,
pull down the Capture menu, choose Setup, and set the Capture
option accordingly.

� Run the program from which you want to capture a graphic. For
example, suppose you want to capture one of the figures on the title
screen of the NECC keynote presentation. Use the finder to look in the
Necc folder on the Multilit CD, and double-click the NECCKeynote to get
it running.

� To capture a rectangular area of an image, press ±-ß-4
and your cursor will change into a crosshair, indicating it is ready to
capture something.

� Drag the crosshair over the area you want to capture. As you drag, the
rectangle expands or contracts to show what will be captured when
you release the mouse button.

� When you release the mouse button, you will hear a clicking sound,
indicating that you just grabbed an image.

� Get Graphic Converter running, if it is not running already.

� Pull down the File menu, and choose Open.

� When the Open dialog appears, use it to look on the Macintosh HD for
the image you just captured; the image will be called something like
Picture 1 or Picture 2, depending on how many images you captured
so far. Double-click the name of the image to open it.

� The captured image will now appear in the Graphic Converter
window. To save the image, pull down the File menu and choose
Save As.

� Use the Format menu to select the image format in which you want
to save the image.

� In the Name field, type the name you want the image to have.
Important: Make sure the filename extension matches the type of file
you selected via the Format menu.

� Click the Save button to save the file, then pull down the File menu
and choose Quit to leave Graphic Converter.

Note: In addition to the ±-ß-4 command that captures a
rectangular region of an image, you can also use ±-ß-3 to
capture the entire screen, or ±-ß-l-4 to
capture the contents of a window.
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Converting Images
Sometimes you encounter situations in which you need to convert an image from one
file format into another. If you plan to put an image on a Web page, for example, the
best formats to use are .gif if the image has 256 colors or less, or .jpg for images with up to
16 million colors. To convert an image from one file format into another, follow the
steps in Table 34-2.

Table 34-2 How to Convert Images from One File Format into Another

Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows) Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)

Figure 34-2 The Paint Shop Pro Save
As dialog.

• Set the file format here

� Pull down the Paint Shop Pro File menu and choose Open; the Open
Image dialog appears.

� In the List Files of Type field, pull down the choices and select the
file format of your original image.

� Browse to the image and click OK to open it; the image will appear
on-screen.

� To convert the image, pull down the File menu and choose Save As;
the Save As dialog appears as shown in Figure 34-2.

� In the Save as Type field, pull down the choices and select either GIF
or JPG.

� Save the file in the folder of your choice (probably your Multilit
folder).

� Make sure the name you give the image has the same filename
extension as the file format you selected (GIF or JPG).

� Pull down the Graphic Converter File menu and choose Open; the
Select a File dialog appears.

� Select the image file you want to convert.

� Pull down the File menu and choose Save As; the Save As dialog
appears as shown in Figure 34-3.

� In the Save As dialog, pull down the Format menu and choose the
format you want (either GIF or JPEG).

� Click the Save button to save the file in the folder of your choice
(probably your Multilit folder).

Figure 34-3 The Graphic Converter Save As dialog.

• Set the file
format here
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Resizing Images
Images may be the wrong size for placement on a multimedia screen or Web page. To
resize an image, follow the steps in Table 34-3.

Table 34-3 How to Resize Images

Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows) Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)

� Pull down the Paint Shop Pro File menu and choose Open; the Open
Image dialog appears

� In the List Files of Type field, pull down the choices and select the file
format of your original image

� Browse to the image and click OK to open it; the image will appear
on-screen.

� To resize the image, pull down the Image menu and choose Resize;
the Resize dialog appears as shown in Figure 34-4.

� Pull down the Graphic Converter File menu and choose Open;
the Select a File dialog appears.

� Select the image file you want to resize.

� Pull down the Picture menu and choose Size, then Scale; the
Scale dialog appears as shown in Figure 34-5.

Figure 34-4 The Resize dialog
in Paint Shop Pro.

• Check this box if you want
the resized image to have
the same proportions as
the original

� Click a size option, such as Percentage of Original, then make the
numbers larger or smaller, depending on whether you want the
image to be larger or smaller. Check the Maintain Aspect Ratio box if
you want the resized image to have the same proportions as the
original.

� Click OK; the resized image appears.

� Pull down the File menu, and either choose Save to save this file
under the same name as the original (this will replace the original
file), or choose Save As to save it under another name.

• Check this box if
you want the
resized image to
have the same
proportions as the
original

� Set the width and height you want the resized image to be. You
can do this by dimension or size.

� Check the Keep Proportions box if you want to maintain the
aspect ratio.

� Click OK.

� Pull down the File menu, and either choose Save to save this file
under the same name as the original (this will replace the
original file), or choose Save As to save it under another name.

Figure 34-5 The Scale dialog in
Graphic Converter.

Show-Me Movie:
“Resizing Images”
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Reducing the Color Depth
Unless you have a special reason for wanting to keep your images encoded in 16 million
colors (24-bit), you should convert the images to 256 colors (8-bit), which will make
them load faster and reduce considerably the file space occupied by the image. To
convert a 24-bit image into an 8-bit image, follow the steps in Table 34-4.

Table 34-4 How to Reduce the Color Depth of an Image

Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows) Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)

� Pull down the Paint Shop Pro File menu, choose Open, and open the
image, which will appear on-screen.

� Pull down the Colors menu, choose Decrease Color Depth, and see if
the 256-colors option is active. If it is not active, your image does not
need to be reduced in color depth, so close the image and skip the
rest of these instructions.

� If the 256-colors option is active, select it; the Decrease Color Depth
dialog appears as shown in Figure 34-6.

� If you choose one of the Optimized palette settings, click the option to
Include Windows Colors. If you plan to publish this image to the Web,
choose Standard/Web-safe.

� Whether to choose Nearest Color or Error Diffusion is up to you. Click
OK to close the dialog.

� Pull down the File menu, and either choose Save to save this file
under the same name as the original (this will replace the original
file), or choose Save As to save it under another name.

Figure 34-6 The Decrease Color Depth dialog in
Paint Shop Pro.

� Pull down the Graphic Converter File menu, choose Open, and open
the image, which will appear on-screen.

� Pull down the Picture menu, choose Colors, then Change to 256
Colors, as shown in Figure 34-7.

� Pull down the File menu, and either choose Save to save this file
under the same name as the original (this will replace the original
file), or choose Save As to save it under another name.

Figure 34-7 Decreasing the color depth with Graphic
Converter.
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Image Special Effects
Both Paint Shop Pro and Graphic Converter have a wide range of image special effects.
You can sharpen or soften an image, for example, or emboss, chisel, weave, or bevel it.
To apply special effects to an image, follow the steps in Table 34-5.

Table 34-5 How to Create Image Special Effects

Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows)Paint Shop Pro (Windows) Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)Graphic Converter (Macintosh)

Show-Me Movie:
“Image Special Effects”

� Open the image with Paint Shop Pro.

� If the image is not already 16 million colors, pull down the Colors
menu, choose Increase Color Depth, and increase the colors to 16
million. The special effects work only on 16-million-color images.

� Pull down the Image menu and choose the kind of effect you want.
On the menu, you will find deformation filters, edge effects, blur,
sharpen, and so on.

� Depending on the effect you choose, a dialog box may appear. If
you choose Effects, Kaleidoscope, for example, the dialog in Figure
34-8 will appear.

� Open the image with Graphic Converter.

� Pull down the Effect menu and choose the kind of effect you want.
On the menu, you will find deformation filters, gamma correction,
and several kinds of dither.

� Depending on the effect you choose, a dialog box may appear. If
you choose Effects, Gamma Correction, for example, the Gamma
Correction dialog in Figure 34-9 will appear.

� Play with the settings in the dialog box until you achieve the desired
effect. If you have a fast computer and you want the full-size image
to update automatically as you adjust the settings, click the Auto
proof box.

� If a dialog box opened, click OK to close it, or click Cancel to cancel
the effect.

� If you want to save the modified image, pull down the File menu
and choose Save As to save the image under the filename you want
it to have.

Figure 34-8 The Kaleidoscope dialog box.

Figure 34-9 The Gamma Correction dialog box.

� Play with the settings in the dialog box until you achieve the
desired effect. If you play with Gamma correction, for example, you
should know that on a computer monitor, a small change in
brightness at a low brightness level is not equal to the same change
at a high level. Gamma correction compensates for this inequality.

� If a dialog box opened, click OK to close it, or click Cancel to cancel
the effect.

� If you want to save the modified image, pull down the File menu
and choose Save As to save the image under the filename you want
it to have.
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Figures 34-10 through 34-15 show the result of applying six different Paint Shop Pro
image effects to the Flying Fortress image in the Aircraft folder of the Multilit CD. These
are just a few of the special effects you will be able to create when you pull down the
Effects menu and let your imagination be your guide.

Figure 34-10 Edge enhanced. Figure 34-11 Rippled.

Figure 34-12 Sculptured. Figure 34-13 Hot waxed.

Figure 34-14 Mirrored. Figure 34-15 Framed in round wood.
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e x e r c i s e s
1. If you have access to the World Wide Web, get on the Web and browse to a screen with an image you would like

to capture. Otherwise, run the NeccKeynote presentation in the Necc folder on the Multilit CD, and go to a slide
that shows an image you like. Get Paint Shop Pro running (Windows) or Graphic Converter (Macintosh). Following
the steps in Table 34-1, try the different capture methods you learned in this chapter for grabbing rectangular
areas of the screen, windows, or the full screen. Which method is most appropriate for capturing the images you
decided to grab? Why does that method work better for you than the others?

2. The photos directory on the Multilit CD contains an image that is too dark. The name of the image is toodark.bmp.
Use Paint Shop Pro (Windows) or Graphic Converter (Macintosh) to enhance the image. Hint: To achieve the best
result, you must not only brighten this image but also increase its contrast. Brightness and contrast are two image
parameters that interact with each other; with experience, you will learn how to make good contrast and
brightness adjustments.


