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Waveform Audio
Recording

After completing this chapter, you will be able to:

� Create a waveform audio recording of your voice or any other sound source

� Set recording levels to ensure a good signal-to-noise ratio

� Make narrated slide shows that tell a story as the user clicks through them

� Understand the concept of ambient sound and learn how to use it to give a sense of

realism to your multimedia screens

� Record sound bites that play when the user mouses over a trigger

� Edit a waveform audio recording to remove unwanted sound

� Experience how the sampling rate and bits-per-sample settings affect the quality of the

sound and the size (required bandwidth) of the waveform audio file

� By definition, every multimedia PC has the capability to record and play back waveform audio. In this chapter you

will learn how to record waveform audio, trigger its playback, and create narrated slide shows. You

will also learn how to record ambient sound to create a sense of realism on a multimedia screen.

Preparing to Make Your First Waveform Audio Recording
In order to complete the exercises in this chapter, you are going to need a microphone.
Some computers have the microphone built in. If your computer does not have a built-
in microphone, you will need to plug in a microphone of your own. If you do not have a
microphone, you can buy one inexpensively at any Radio Shack store. If the connector
on your microphone does not fit the microphone jack on your computer, you can
purchase the necessary adapter from Radio Shack.

Once your microphone is connected, you need to make sure it is selected as the source in
the recording section of your computer’s sound mixing software. Follow the steps in
Table 25-1 to do that.
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Show-Me Movie:
“How to Select the Record
Sound Source”
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Table 25-1 How to Select the Record Sound Source

WindowsWindowsWindowsWindowsWindows MacintoshMacintoshMacintoshMacintoshMacintosh

�  If there is a sound icon on your Windows taskbar, double-click it to bring up your sound mixer
controls. Otherwise, look on your Windows Start menu for a group related to sound, in which you
should be able to find your sound mixer software.

� Pull down the Options menu and choose Properties; the Properties dialog appears as shown in
Figure 25-1.

�  Pull down the Apple menu, choose
Control panels, and choose Monitors
and Sound. When the control panel
opens, choose Sound. You will get a
Sound Control panel similar to the one
shown in Figure 25-4.

Figure 25-1 The Sound
Properties dialog.

Click here to see •
Playback  settings •

Figure 25-2 The Recording
Control window.This box must be checked in •

 order to record from a •
 microphone •

Figure 25-3 The Volume
Control window.

Master volume •
 control •

Figure 25-4 The Sound Control
Panel.

Figure 25-5 The Sound
Monitoring Source menu.

� Click the Recording button, if it is not already selected.

� The listbox identifies the different recording controls on your computer. Make sure they are all
selected, so they will show up in the Recording Control window in the next step.

� Click OK; the Recording Control window appears as shown in Figure 25-2.

� Make sure the check box for the source you’re recording is selected. In this example, check the
microphone source.

� Pull down the Options menu and choose Properties to make the Properties dialog shown in
Figure 25-1 reappear.

� Click the Playback button.

� The listbox identifies the different playback controls on your computer. Make sure they are all
selected, so they will show up in the Volume Control window in the next step.

� Click OK; the Volume Control window appears as shown in Figure 25-3.

� If you are recording from a microphone, you will probably want to mute the microphone; otherwise,
sound from the microphone will feed back through your speakers. Feedback can cause distortion,
but it can also create an interesting depth effect if your microphone is not positioned too close to
the speakers. The author recommends you mute the mike setting your first time through; later on,
you can try making depth effects.

� Make sure the master volume control is turned up.

� Pull down the Sound Monitoring Source
menu; it lets you set the sound source
to external mike, audio CD, sound in, or
built-in mike, as illustrated in Figure
25-5.

� In this example, click the built-in mike
to select it as your input source, unless
you happen to have an external mike,
in which case you should select it
instead.

� Click the Close icon in the upper left
corner of the control panel to close it.

Click here to see •
 Record settings •

Make sure these boxes •
are all checked •

The slider adjusts the record •
 level; it should be up about •

 90% of the way; increase this •
if the recording sounds too •

 faint; decrease this if you •
  get distortion •

Microphone Control; •
 mute this to avoid •

 feedback while •
 you’re recording •

 from a microphone •

The slider adjusts the •
 playback volume •
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Making Your First Recording
PowerPoint has a simple waveform audio recorder built in that makes it easy for you to
record a simple narration for a slide. The tool does not let you edit the recording, so it is
limited in that respect, but it is so easy to make your first recording that we will start with
it before learning a more complete tool later on in this chapter. Not to belittle the
PowerPoint audio recording tool, however; even experienced professionals use it to
record short narrations called sound bites because it is so quick and easy to do. Follow
these steps to make your first recording:

� Go to the PowerPoint screen on which you want to record some waveform audio. In
this example, let’s create a new screen on which to place your first recording. Go to the
last screen of your Practice application, and click the New Slide icon or pull down Insert
and choose New Slide to create a new blank screen.

� To make your first recording, pull down the Insert menu, choose Movies and Sounds,
and select the option to Record Sound, as illustrated in Figure 25-6. If the Record
Sound option is not visible, click the down-arrows to expand the menu and reveal the
rest of the choices.

� The Record Sound dialog will appear, as illustrated in Figure 25-7.

� Into the Name field, type the name you want the recorded sound to have. In this
example, type My First Narration

� To begin recording, hold the microphone close to your mouth so you will get a good
presence on mike; then click the Record button, which is the button with the solid red
circle inside it. Start talking immediately, and say anything you want. For example, you
might say: “This is my first recorded narration.”

� Click the Stop button as soon as you are done, so you do not record unwanted silence
at the end of the recording. The Stop button is the one with the square in it.  The
square is blue when the button is active, or gray when it is inactive.

� To rehearse your recording, click the Play button, which is the one with the arrow in it.
Listen as the recording plays back.

� If you do not like the recording, click Cancel. Then repeat these steps to try it again.

If you like the recording, click OK. An audio icon appears on your slide. When you run
the presentation, the recording will play when you click on this audio icon.

• Play

Figure 25-6 Selecting the option to Record Sound
from the Movies and Sounds section of the Insert menu.

Figure 25-7 The Record Sound dialog.

Show-Me Movie:
“Recording Sound with
PowerPoint”

• Stop
• Record
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Checking Record Levels
If the recording sounds faint, it is possible that the record level is turned down too low
on your computer. You may be tempted to turn up the volume on your amplifier, but
that is not the proper solution, because doing that will also amplify background noises
due to the recording level having been set too low. Instead, use your Recording Control
window to check the record level and adjust it if necessary. Refer back to Table 25-1 if
you need help getting the recording controls to appear on-screen.

Recording Narrations
The simple technique you have just learned for making voice recordings with PowerPoint’s
built-in audio recorder can be used to narrate any slide or object in a presentation. An
effective technique in training, for example, is to use audio narration to explain things as
they appear on-screen. Let’s create a simple example that shows you how to do this. We
will make an example that has three slides, so you can practice the technique three times.
Follow these steps:

S L I D E  1 :  T H E  E G G

� Pull down the PowerPoint File menu and choose New to create a new presentation to
hold this example. When the New Presentation dialog appears, choose the option to
create a Blank presentation. When the New Slide dialog appears, choose the option to
create a Blank slide.

� Pull down the Insert menu, choose Picture, then choose From File. When the Insert
Picture dialog appears, use the Look In menu to go to the Images folder of the Multilit
CD, and choose the image called Egg.

� Click and drag the corners of the picture of the egg to make it fill the screen.

� Pull down the Insert menu, choose Movies and Sounds, then Record sound. When the
Record Sound dialog appears, use it to record the following narration: “Roosters grow
through several interesting stages. Here you see how they get born: in eggs!”

� Click the Play button to make sure the recording sounds good. If not, click Cancel, and
repeat the previous step. If the recording is OK, use the Name field to make its name
Eggs, then click OK.

� The audio icon appears on top of the Egg slide. Right-click the audio icon, choose
Order, and choose Send to Back.

� Right-click the Egg slide and choose Custom Animation. Use the Custom Animation’s
Order and Timing tab to make the audio recording start automatically.

� Click the Slide Show button to rehearse the show so far. As soon as the egg appears
on-screen, the narration should play automatically. If there is a problem, go back and
fix it.

� Pull down the File menu, choose Save, and when the Save dialog appears, use the
Save In menu to choose the multilit folder on your hard drive, and save the
presentation under the filename: Roosters
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S L I D E  2 :  T H E  C H I C K

� Click the New Slide icon to add a blank slide after the Egg.

� Pull down the Insert menu, choose Picture, then choose From File. When the Insert
Picture dialog appears, choose the image called Chick from the Images folder on the
Multilit CD.

� Click and drag the corners of the picture of the chick to make it fill the screen.

� Pull down the Insert menu, choose Movies and Sounds, then Record Sound. When the
Record Sound dialog appears, use it to record this narration: “Then they hatch into
little chicks.”

� Click the Play button to make sure the recording sounds good. If not, click Cancel, and
repeat the previous step. If the recording is OK, use the Name field to name it Chick,
then click OK.

� The audio icon appears on top of the Chick slide. Right-click the audio icon, choose
Order, and choose Send to Back.

� Right-click the Chick slide and choose Custom Animation. Use the Custom Animation’s
Order and Timing tab to make the audio recording start automatically.

� Click the Slide Show button to rehearse the show so far; the audio on each slide should
begin automatically soon as the slide appears.

� Pull down the File menu and choose Save, or click the Save icon, to save your work
so far.

S L I D E  3 :  T H E  R O O S T E R

� Click the New Slide icon to add a blank slide after the Chick.

� Pull down the Insert menu, choose Picture, then choose From File. When the Insert
Picture dialog appears, choose the image called Rooster from the Images folder on the
Multilit CD.

� Click and drag the corners of the picture of the rooster to make it fill the screen.

� Pull down the Insert menu, choose Movies and Sounds, then Record Sound. When the
Record Sound dialog appears, use it to record the following narration: “Eventually,
they grow up and look like this. And then they start to crow!”

� Click the Play button to make sure the recording sounds good. If not, click Cancel, and
repeat the previous step. If the recording is OK, use the Name field to name it Rooster,
then click OK.

� The audio icon appears on top of the Rooster slide. Right-click the audio icon, choose
Order, and choose Send to Back.

� Right-click the Rooster slide and choose Custom Animation. Use the Custom
Animation’s Order and Timing tab to make the audio recording start automatically.

� Click the Slide Show button to rehearse the show so far; the audio on each slide should
begin automatically soon as the slide appears.

� Click the Save icon to save the presentation.
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Ambient Sound
Ambient sound is a multimedia technique in which a waveform audio file keeps repeating
to create the aural illusion that the user is in the place or situation where the sound was
recorded. PowerPoint makes it easy to put ambient sound on any multimedia screen.
Follow these steps:

� Go to the slide on which you want to insert some ambient sound. In this example, go
to the last screen of the Rooster application, and click the New Slide icon to create a
new blank screen.

� Pull down the Insert menu, choose Picture, then choose From File. When the Insert
Picture dialog appears, choose the image called Rooster from the Images folder on the
Multilit CD.

� Pull down the Insert menu, choose Movies and Sounds, then choose Sound from File.

� When the Insert Sound dialog appears, look in the Ambient folder of the Multilit CD,
and choose the ambient sound of your choice. In this example, choose Rooster.

� When PowerPoint asks if you want the sound to play automatically, answer Yes. The
sound’s audio icon appears on-screen.

� Right-click the audio icon, and choose the option to edit the sound object. When the
Sound Options dialog appears, choose the option to Loop until stopped.

� Click the Slide Show button to rehearse the application. When you get to the slide that
has the ambient sound, listen how it loops continually.

In the next section of this book, when you create the History of Flight application, you
will use ambient sound to make it sound like your users are standing in an airport lobby.

Adding Custom Sound to a Hyperlink
You can add custom sound to a hyperlink to give the user an audible hint about what
will happen if the user triggers the link. For example, suppose you want to insert a
hyperlink at the end of your Practice application that will trigger the Rooster application
you created in this chapter. When the user mouses over the hyperlink, you will play a
narration telling what will happen if the user clicks there. Follow these steps:

� Use PowerPoint to open the Practice application and scroll down to the last screen.

� Pull down the Insert menu, choose Movies and Sounds, and choose Record Sound.
When the Record Sound dialog appears, record the following narration: “Click here to
find out what came first: the chicken or the egg?”

� Make the name of the recorded narration RoosterLink, then click OK to close the
Record Sound dialog. The audio icon for the narration you recorded should now
appear on-screen.

� Pull down the Insert menu, choose Picture, then choose From File. When the Insert
Picture dialog appears, choose the image called Rooster from the Images folder on the
Multilit CD.

Show-Me Movie:
“Adding Custom Sound to a
Hyperlink”
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� Resize the picture of the rooster so it appears as a little icon on your screen.

� Right-click the rooster icon, and when the menu appears, choose Hyperlink.

� When the Hyperlink dialog appears, choose the option to browse for a file, and in the
multilit folder on your hard drive, choose the Rooster application and click OK to close
the dialog.

� Right-click the hyperlink you just created, and choose Action Settings to make the
Action Settings dialog appear.

� Click the Mouse Over tab, check the Play Sound check box, pull down the menu, and
choose the RoosterLink audio you just recorded, as illustrated in Figure 25-8.

� Click the Slide Show button to run the application. When you get to the screen on
which you put the hyperlink, mouse over it, but do not click. Notice how mousing over
it causes the narration you recorded to play: “Click here to find out what came first: the
chicken or the egg.”

Waveform Audio Recording and Editing
Although PowerPoint’s built-in waveform audio tool is quick and easy to use for brief
narrations, it does not let you edit the audio if you make a mistake or if you need to
update something that goes out of date. Windows comes with a program called the
Sound Recorder that enables you to create and edit waveform audio recordings. The
remainder of this chapter shows Windows users how to record and edit waveform audio
with the Sound Recorder. Macintosh users can edit audio with the QuickTime Pro
software featured in Chapter 35.

Figure 25-8 Making the Action Settings trigger a
sound when the user mouses over a hyperlink.
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Get the Windows Sound Recorder running by following these steps:

� Click the Windows Start button.

� Choose Programs—Accessories—Multimedia—Sound Recorder.

� The Sound Recorder appears as shown in Figure 25-9. The green line in the black
window is an oscilloscope that shows you the incoming sound wave. When you press
the Record button to begin recording, the green line should oscillate as the sound
comes in. If the line does not move, your sound source is not active. Review the
instructions in Table 25-1 to fix the problem.

� To begin recording, click the Record button. If you are using a microphone, hold the
mike close to your mouth, so your recording will have good presence of sound. Speak
in a loud, clear voice.

� To stop recording, click the Stop button.

� To hear the recording, click the Play button. If you do not hear anything, your sound
source is probably not connected properly. Make sure your microphone or line input is
plugged in to the proper jack, and follow the steps in Table 25-1 to select it as the
recording source.

� To rewind the recording, click the Rewind button.

� To save the recording, pull down the File menu and click Save As; the Save As dialog
appears. Save the recording in the folder of your choice, such as your multilit folder.

� If the recording sounds too faint, you need to adjust the record level; pull down the
Edit menu, choose Audio Properties, and turn up the recording level.

� If you hear distortion, you need to turn the record level down; pull down the Edit
menu, choose Audio Properties, and turn down the recording level.

� It may take you several tries to get a good recording. Keep adjusting the settings and
rerecord until you get the result you want.

� To rerecord, pull down the File menu and choose New to empty the waveform buffer.
If you do not choose New, what you record next will get inserted into what has already
been recorded.

• The scope graphs the incoming sound wave

Figure 25-9 The Windows Sound Recorder.

• Rewind
• Fast-Forward

• Play • Stop • Click here to Record
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Editing Waveform Audio Recordings
In addition to letting you record waveform audio, the Sound Recorder enables you to
edit the audio. For example, if you pressed the Record button too soon, there is extra
sound at the beginning of the recording that you need to delete. Similarly, if you pressed
the stop button too late, there is extra sound at the end that you will want to remove. To
edit a waveform audio recording, follow these steps:

� Get the Sound Recorder running if it is not already on-screen.

� Pull down the File menu, choose Open, and open the waveform audio file you want to
edit. If the file is already open, you can skip this step.

� Play the file, and make note of the spots at which you want to delete the sound. You
can drag the slider to move quickly to different positions in the recording. The Position
counter shows where you are in hundredths of seconds.

� To delete the first part of a recording, position the slider at the spot where the good
stuff starts, then pull down the Edit menu and choose Delete Before Current Position.

� To delete the last part of a recording, position the slider at the end of the good stuff,
then pull down the Edit menu and choose Delete After Current Position.

� Play the file to make sure you have what you wanted.

� Save the file.

Adjusting the Quality of Waveform Audio Recordings
Most waveform audio recording software lets you adjust two parameters that govern the
quality of a waveform audio recording: sampling rate and bits per sample. Be aware that
the higher you set these parameters, the larger your waveform audio file will be.

S A M P L I N G  R A T E

The sampling rate determines the frequency response of the recorded sound. To record
frequencies faithfully, your sampling rate must be at least two times greater than the
highest frequency you want to record. However, the higher you set the sampling rate,
the larger your waveform audio file will be. Since the size of the file increases, you should
not choose a higher sampling rate than you need because of the increased bandwidth
required to transfer the file over the Internet. To help you grasp the relationship between
sampling rate and sound quality, Table 25-2 compares different sampling rates to real-
world audio devices of differing fidelities.

Table 25-2 The Relationship Between Sound Quality and Sampling Rate

Samples per SecondSamples per SecondSamples per SecondSamples per SecondSamples per Second Sonic EquivalentSonic EquivalentSonic EquivalentSonic EquivalentSonic Equivalent

6,000 Telephone

15,000 AM radio

37,500 FM radio

40,000 Phonograph records

44,100 Compact disc
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B I T S  P E R  S A M P L E

Table 25-3 illustrates how the number of bits per sample determines the dynamic range,
which determines how much of a volume change you will hear between the loudest and
softest sounds in a recording. Waveform audio devices typically give you a choice of 8 or
16 bits-per-sample.

Since file size is determined by multiplying the bits per sample by the sampling rate, you
do not want to choose a higher bits-per-sample setting than required. Try recording at 8
bits per sample first. Only if that does not provide adequate sound quality should you
increase the setting to 16 bits. To help you grasp the relationship between bits per
sample and sound quality, Table 25-4 shows the dynamic range equivalents of some
real-world sound sources.

Table 25-4 Bits-per-Sample Equivalents of Traditional Sound Sources

Sound SourceSound SourceSound SourceSound SourceSound Source Bits-per-Sample EquivalentBits-per-Sample EquivalentBits-per-Sample EquivalentBits-per-Sample EquivalentBits-per-Sample Equivalent

AM radio 6 bits

Telephone 8 bits

FM radio 9 bits

Phonograph records 10 bits

Reel-to-reel Tape 11 bits

Compact Disc 16 bits

Table 25-3 The Relationship Between Bits per Sample and Dynamic Range

Bits per SampleBits per SampleBits per SampleBits per SampleBits per Sample Dynamic RangeDynamic RangeDynamic RangeDynamic RangeDynamic Range Bits per SampleBits per SampleBits per SampleBits per SampleBits per Sample Dynamic RangeDynamic RangeDynamic RangeDynamic RangeDynamic Range

1 8 dB* 10 62 dB

2 14 dB 11 68 dB

3 20 dB 12 74 dB

4 26 dB 13 80 dB

5 32 dB 14 86 dB

6 38 dB 15 92 dB

7 44 dB 16 98 dB

8 50 dB 17 104 dB

9 56 dB 18 110 dB

*dB is the abbreviation for decibel
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Bandwidth Considerations
If you are using the Windows Sound Recorder, you can modify the sound quality
settings by pulling down the Edit menu and choosing Audio Properties to make the
Audio Properties dialog appear as shown in Figure 25-10. To adjust the quality, pull
down the Preferred Quality menu, and choose the setting you want. If you understand
how bits per sample and dynamic range affect sound, you can click the Customize
button to create your own custom settings. Be careful to keep bandwidth in mind,
however, because the higher you set the quality adjustments, the larger the file will
become, and the more space it will take up on your computer. If you are planning to
publish your application on the Internet, bandwidth may also be a consideration,
because larger audio files take longer to download and play from the Web.

Figure 25-10 The Audio Properties dialog.

e x e r c i s e s
1. If you completed the Rooster application that you created while working through this chapter, the rooster crows

incessantly when the user gets to the final screen on which you inserted the ambient sound. Some users might
want to silence that screen. Put a Silence button there. Hint: One of the options on the Action Settings dialog’s
Play Sound menu is to stop the previous sound.

2. After you complete exercise 1, add a button that makes the ambient sound resume. Try the buttons and make
sure the user can press your Silence button to stop the sound, then press Resume to restart it.

3. If you have Windows, use the Windows Sound Recorder to record 10 seconds of your voice at 8 bits and then at 16
bits per sample. Save the first recording as c:\multilit\8bit.wav, and save the second recording as
c:\multilit\16bit.wav. Play the files back repeatedly and compare them. Can you hear a difference between the two
recordings? Use the Windows Explorer to inspect the size of these files. How much larger is the 16-bit recording?

4. If you have Windows, use the Windows Sound Recorder to record music at different sampling rates. Can you hear
how the higher sampling rates result in a brighter recording? This is because lower sampling rates cannot record
high frequencies, effectively filtering them out.




