At a minimum, these comments must include name, date, class, and
section number, along with a brief description of what the program
does. If the program is related to a particular assignment, the
assignment and problem number must be included. If the program uses a
particular algorithm for solving a problem, that must be stated also.
Good naming is difficult. A name should indicate the purpose of the item being named. However, naming an int variable "intVar" does not add any useful information, so follow the programming conventions used in class if you cannot use a better name like "input" or "radius" or "continueFlag".
Do not use comments to make up for using bad names. Spend time on the names instead. Comments should only point out special features of your code, or be used to isolate major sections visually (though this is often better accomplished with whitespace).
Here is bad commenting for bad
naming: